NO-IP DDNS Script for Mikrotik – 2024

If you are using NO-IP for all your network devices including Mikrotik and wants to use no-ip as a backup alongside Mikrotik Cloud default. You can use the below script and schedule it as what you want.

# Data to be modified
:local noipuser “username”
:local noippass “MyStr0ngPassWoRd!”
:local noiphost “mydomain.sytes.net”

# From now on, do not modify
:local cIP [/ip cloud get public-address]

:if ([:resolve $noiphost] != $cIP) do={
# Important, has been replaced “?” with “\3F” to avoid problems.
/tool fetch url=”http://$noipuser:[email protected]/nic/update\3Fhostname=$noiphost&myip=$cIP” keep-result=no
:log info “NO-IP: $noiphost -> IP updated: $cIP”
} else={
:log info “No-IP: No update needed. Current: $cIP”
}

 

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top